Customer Service - Phone Systems
Incident Report for FinanceIt Canada Inc.
Resolved
Our upstream telephony vendor has confirmed that the issue has been resolved now. We apologize for this inconvenience. Thank you for your patience.
Posted Aug 19, 2019 - 15:29 EDT
Investigating
We are currently having issues with our upstream telephone provider and although we are able to receive calls, some callers may not be able to route through. In the meantime, please contact us via email at service@financeit.io for now. We apologize for the inconvenience.
Posted Aug 19, 2019 - 13:24 EDT
This incident affected: Customer Phone Support.