Financeit - Possible Site Service Interruption
Incident Report for FinanceIt Canada Inc.
Resolved
This issue has now been resolved. We apologize for the inconvenience.
Posted Jul 24, 2023 - 17:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted Jul 24, 2023 - 15:38 EDT
Investigating
We have detected that some of our users may be experiencing some possible service disruption. We are investigating and working hard to restore our site to optimum status.
Posted Jul 24, 2023 - 15:32 EDT
This incident affected: Financeit Platform.