Financeit Canada - Customer Service
Incident Report for FinanceIt Canada Inc.
Resolved
This issue has been resolved. You can reach us again at our main phone number 1-888-536-3025 (although the temp number will redirect your call back to the primary one). We apologize for this inconvenience.
Posted Jun 13, 2023 - 16:53 EDT
Identified
Temporary Phone Support Number

Due to an Amazon Web Services (AWS) outage impacting companies globally, our regular toll free line is currently unavailable. We have set up a temporary toll free number so that we can continue to offer you support over the phone. If you require assistance please feel free to give us a call at 1-833-509-2021 or you can reach us by email at service@financeit.io. Thank you for your patience.

Numéro d'assistance téléphonique temporaire

En raison d'une panne d'Amazon Web Services (AWS) affectant les entreprises du monde entier, notre ligne téléphonique gratuite est actuellement pas disponible. Nous avons mis en place un numéro gratuit temporaire afin de pouvoir continuer à vous offrir une assistance par téléphone. Si vous avez besoin d'aide, n'hésitez pas à nous appeler au 1-833-509-2021 ou vous pouvez nous joindre par courriel à service@financeit.io. Merci de votre patience.
Posted Jun 13, 2023 - 16:25 EDT
This incident affected: Customer Phone Support.