Financeit - Possible Site Service Interruption
Incident Report for FinanceIt Canada Inc.
Resolved
This incident has now been resolved. Sorry for the inconvenience
Posted Oct 26, 2023 - 11:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2023 - 10:43 EDT
Investigating
We have detected that some of our users may be experiencing some possible service disruption. We are investigating and working hard to restore our site to optimum status.
Posted Oct 26, 2023 - 10:41 EDT
This incident affected: Financeit Platform.