Financeit - Possible Site Service Interruption
Incident Report for FinanceIt Canada Inc.
Resolved
This incident has now been resolved. Thank you for your patience.
Posted Dec 14, 2023 - 16:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2023 - 15:48 EST
Update
We are continuing to investigate but the service has been back online now for about 20 minutes now.
Posted Dec 14, 2023 - 15:00 EST
Investigating
We have detected that some of our users may be experiencing some possible service disruption. We are investigating and working hard to restore our site to optimum status.
Posted Dec 14, 2023 - 14:37 EST
This incident affected: Financeit Platform.