Customer Service - Phone Systems
Incident Report for FinanceIt Canada Inc.
Resolved
The incident has been resolved. We apologize for the inconvenience.
Posted Nov 12, 2019 - 16:36 EST
Investigating
We are currently having issues with our upstream telephone provider and although we are still able to receive calls, some callers may not be able to route through. In the meantime, please contact us via email at service@financeit.io for now. We apologize for the inconvenience.
Posted Nov 12, 2019 - 14:39 EST
This incident affected: Customer Phone Support.