Financeit Marketing Site is currently down
Incident Report for FinanceIt Canada Inc.
Resolved
This incident has now been resolved.
Posted Dec 28, 2022 - 16:48 EST
Monitoring
We have implemented a fix to resolve this issue. We will be monitoring it for a few more minutes before closing off the incident. We apologize for the inconvenience.
Posted Dec 28, 2022 - 16:43 EST
Investigating
Our Financeit.io website is currently down due to a misconfiguration. We are actively working to restore it.
Posted Dec 28, 2022 - 16:26 EST
This incident affected: Financeit Marketing Website.