Financeit - Possible Site Service Interruption

Incident Report for FinanceIt Canada Inc.

Resolved

A fix has been implemented and the site is now back online. We apologize for this inconvenience.
Posted May 24, 2023 - 10:47 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 24, 2023 - 10:43 EDT

Investigating

We have detected that some of our users may be experiencing some possible service disruption. We are investigating and working hard to restore our site to optimum status.
Posted May 24, 2023 - 10:36 EDT
This incident affected: Financeit Platform.