Site Performance Issues
Incident Report for FinanceIt Canada Inc.
Resolved
The issue has now been resolved. Apologies for the inconvenience.
Posted Mar 17, 2021 - 13:27 EDT
Monitoring
We have implemented a fix and are expecting it to be fully in effect by 12 PM EST. We apologize for this inconvenience
Posted Mar 17, 2021 - 06:55 EDT
Investigating
Please be advised that we experienced some system issues last night. Unfortunately, this has a notable impact to anything around search functions within the site. We have implemented a fix and are expecting it to be fully in effect by noon. We apologize for this inconvenience
Posted Mar 17, 2021 - 06:55 EDT
This incident affected: Financeit Platform.