Financeit Canada Site Increased Error Rates
Incident Report for FinanceIt Canada Inc.
Resolved
This incident has now been resolved.
Posted Jun 13, 2022 - 15:27 EDT
Monitoring
A fix has been implemented and we're seeing positive results so far.
Posted Jun 13, 2022 - 15:18 EDT
Identified
Please be advised that Financeit is currently observing elevated error rates around loan submissions and loan changes. We are currently implementing a fix to resolve this.
Posted Jun 13, 2022 - 14:59 EDT
This incident affected: Financeit Platform.