Financeit Canada Site Increased Error Rates
Incident Report for FinanceIt Canada Inc.
Resolved
This incident has now been resolved. Sorry for the inconvenience.
Posted Sep 09, 2022 - 11:28 EDT
Monitoring
The issue has been fixed and we're monitoring the performance before we close the incident.
Posted Sep 09, 2022 - 11:17 EDT
Investigating
We are currently investigating increased error rates on the Financeit site. We're working hard to resolve the issue.
Posted Sep 09, 2022 - 11:10 EDT
This incident affected: Financeit Platform.